Cult coaster questions

Related:
Create New Tag

1/13/2014 5:12 AM
Edited Date/Time: 1/13/2014 5:12 AM

Okay my coaster comes in today and now all of a sudden I'm hearing people bitch about it? What's wrong with it? Or is dumbs shits that don't know what they're doing with it. My friend has it amd it's smooth. And any video in how to re grease it and what kind if grease and any other info on it?

|

Refs - Night Light(x2), TCbmx(x2), metalheadification, netty speghetti, Dee Hos, burkminipup, Jon_rides_Eastern, ridebmx34, ScramHype, Wolfen, mnsketch, EmpireMonopoly, howlerfbm, ThomasEller, ii Krxfted, zachhendrix, pcoco,

Phone - 704 - 797 - 6844

1/13/2014 6:05 AM

I think its the dumb shits thing. Mines great, and it comes apart like other khe styled coasters. And I just used normal grease

|



NEW Bike check
That InstaGram ting - @EddiMundo
Raw Clips Edit

KriB Life YouTube channel (Click on the pic!)


1/13/2014 6:10 AM

I dont think that there is something wrong with it, but this kind of questions should be asked before buying.

|

RIDE OR DIE



THE ROUTER

Instagram: Luislorentebmx

1/13/2014 7:16 AM

I dont think it's any actual problems just people that dont know what they're doing with it or the hub just needs to be broken in still.

|

Murica bike check
REFS four, tomdon, bmx1995, jared42069, obiwan chromoly, hate breeder, nshs2010, asilva23, rascio,
Alfred NYC, Kymike, chuck8273(kind of), tc86, Ugot2dewitt, LLURider, dprc, ecuadevil, scramhype, Mario.villegas90(X2), dirtstars22, Brian_Griffin

1/13/2014 7:32 AM

Mine acts up occasionally, BUT it is the ORIGINAL Geisha hub shell with a reverse solid axle in it, and to save money I got bearings and had to shim the inner race of the driver bearings.

Somethimes my clutch take a little extra crank to catch, which is frustrating, but I don't want to spend 160-200 on a new hub for something I just tinker with occasionally.

|

"Hey anybody ever make that mistake like right when you wake up in the morning and you believe in yourself?" -Kyle Kinane

"BIKES!" -Tom Segura

1/13/2014 6:38 PM
Edited Date/Time: 1/13/2014 6:39 PM

Got mine and i've had problems with it. Although I did know what I was doing, as i've had two other coasters before this one. I had a problem with ghost pedalling and a grinding hub whenever the cones were tightened even slightly. Taking it apart was pretty difficult the first time, it took a lot of hammering to get the axle out, but I've greased it and it's running a lot better now, still grinds a little though. I think it needed to be broken in.

Now that it's working though it's definitely my favourite of the other ones I've had (colony, alienation).

When you get yours, make sure you ride it around for a session or two then open it up and chuck some grease on there.

|

1/13/2014 7:50 PM



This video helps all your questions about freecoasters.
|

References: OneGuyIlluminatiEye, robinson79, Brian Griffin, The Horror Contact, StoreBoughtChild, C_Johnsonbmx, dkTechEthan, etc.