Free coaster question

Related:
Create New Tag

4/27/2016 8:46 AM

Does anyone know why it takes my freemix to engage after two full cranks it randomly started doing it?

|

4/27/2016 9:38 AM
Edited Date/Time: 4/27/2016 9:38 AM

My friend's Freemix did this, he never got to fixing it and just bought a new one, so I don't know exactly what the problem was, but I assume it's something with the disengagement system in the hub. Maybe just disassemble and rebuild?

|

Scooter kid trying to ride BMX.
Instagram: @scootereyn

4/27/2016 9:57 AM

Mine was doing this. It was because I had tightened my non drive side nut too much before tightening my drive side, causing the axle to sit off a little bit. It could also be the ball springs on the axle.

I recommend taking everything apart, thoroughly cleaning every piece, and then put a whole bunch of grease on it all. Tighten the driveside nut first when putting it back together.

|




Refs : SnM An1mal, GThompson121, Chuck8273, blizzbikes, bmxsteve99, kevin.brock.338, zinum, Brian_Griffin, billyhandyjunior, riverM, tomdon
Instagram : @timhankinsbmx


4/27/2016 10:38 AM

A while back when KHE dropped their first freecoaster, the KHE reverse i think, i bought it and it was doing the same thing. I found out that it was becuase i had tightened one of my axle nuts to tight or in the wrong order. It was also engaging at weird times while in fakie. I never did get used to the lag when engaging so i just when back to a cassette, plus i mostly ride trails. But anyway, hope this helps.

|

That moment in life when you realize everything is either a potato, or not a potato.

4/27/2016 9:58 PM

I hope mine doesn't do this. It's only 2 weeks old. I know they need maintenance, but I hate taking my wheels off my bike, so....

|

Latest Bike Check/Update





Bought from: adam1234, tomdon (2), oscarbmx, the balt, smokesmokesmoke