Headset

Related:
Create New Tag

3/16/2014 7:41 PM

My headset/handlebar area feels like its loose 24/7, when i have it completely tightened down. I made sure enough of the steerer tube is in the stem clamping area and that the bolt actually compresses the headset, but no luck. Anybody have any suggestions on how i can fix it?

|

Refs: 360Xuprider, Hatebreeder, MrHavoc1988


Email: Shanebaker6969@yahoo.com

!!!My Bike Check!!!

3/16/2014 7:43 PM

Make sure your stem is at least about 3mm above the top of your steerer tube. It might be bottoming out when you tighten your compression bolt down

|

3/16/2014 7:43 PM

Probably need more spacers

|

Murica bike check
REFS four, tomdon, bmx1995, jared42069, obiwan chromoly, hate breeder, nshs2010, asilva23, rascio,
Alfred NYC, Kymike, chuck8273(kind of), tc86, Ugot2dewitt, LLURider, dprc, ecuadevil, scramhype, Mario.villegas90(X2), dirtstars22, Brian_Griffin

3/16/2014 7:45 PM

I had a shitload of spacers on and i took one off and it actually helped a little bit.... if i ever get ahold of a camera ill post a pic

|

Refs: 360Xuprider, Hatebreeder, MrHavoc1988


Email: Shanebaker6969@yahoo.com

!!!My Bike Check!!!

3/16/2014 8:15 PM

Bearing/headtube/steerer tube may be ovalized.

|




Refs : SnM An1mal, GThompson121, Chuck8273, blizzbikes, bmxsteve99, kevin.brock.338, zinum, Brian_Griffin, billyhandyjunior, riverM, tomdon
Instagram : @timhankinsbmx


3/16/2014 8:17 PM

HardBMX_Tim wrote:

Bearing/headtube/steerer tube may be ovalized.

Oh shit, this too. Slipped my mind, but this could very well be the problem. My old Sunday had a slightly ovalized headtube, creaked like hell if spun slowly & always had a tiny wobble to it no matter how tight I would make the compression bolt.

|