Horrible Creak every pedal

Related:
Create New Tag

5/5/2020 1:49 PM
Edited Date/Time: 5/5/2020 1:49 PM

Getting a horrible noise when peddling, seems to be drive side? Running a primo mix on mutiny cranks, chains fairly new, and just installed a new BB, cranks seem fine spindles in perfect condition, all greased and put back together when put new BB in, chain is running straight. Back hub seemed a bit messed but all bearings seem fine. I’ll attach a video if anyone can help! Just ordered a new back wheel hopefully sort it but any ideas?

Thanks a lot!

|

5/5/2020 1:53 PM

HyperBmx1997 wrote:

Getting a horrible noise when peddling, seems to be drive side? Running a primo mix on mutiny cranks, chains fairly new, and just installed a new BB, cranks seem fine spindles in perfect condition, all greased and put back together when put new BB in, chain is running straight. Back hub seemed a bit messed but all bearings seem fine. I’ll attach a video if anyone can help! Just ordered a new back wheel hopefully sort it but any ideas?

Thanks a lot!

Could be a number of things...but I'd suggest taking a look at the BB spacer between the bearings.

|

5/5/2020 2:00 PM

I’ve checked the BB , looked okay but replaced it , got the spacer down to the correct size and cranks spin free, it’s usually every 3 peddle revolutions and it’ll make like a cranking noise,

|

5/5/2020 2:25 PM

HyperBmx1997 wrote:

I’ve checked the BB , looked okay but replaced it , got the spacer down to the correct size and cranks spin free, it’s usually every 3 peddle revolutions and it’ll make like a cranking noise,

Could be misaligned or tight spot in the chain, are you greasing your cranks/spindle?

|

Come back with a warrant.

5/5/2020 2:30 PM

It's usually loose crank bolts, sprocket bolt, or lack of grease somewhere.

|

5/5/2020 2:34 PM

Yeah I’ve greased the spindle up etc, running mutiny cranks so there 2 piece so can’t really (well I think) over tighten the one crank bolt, and yeah I’m hoping it’s the chain, I ended up ordering a new back wheel to cover it as I thought the cassette etc was finished with my primo, but it’s got to the chain, cranks are all over spindle etc seem fine, sprockets straight, new BB I’ve tried everything just waiting on my new wheel but was lost 😅

|

5/5/2020 3:10 PM

My headset creeks when it gets a tiny bit loose. Only creeks when I pedal hard because I'm using the bars for more torque..

|





5/5/2020 9:06 PM

Are your spokes loose?

|

fack off

5/5/2020 10:19 PM

Its usually a sign to grease your spindle

|

I believe in hub guard protection

5/6/2020 7:53 AM

HyperBmx1997 wrote:

I’ve checked the BB , looked okay but replaced it , got the spacer down to the correct size and cranks spin free, it’s usually every 3 peddle revolutions and it’ll make like a cranking noise,

Perhaps not the ideal solution...but after trying 2 separate spacers and still no fix. I removed the spacer completely and noise went away.

|