Hub Guards stuck

Related:
Create New Tag

6/12/2013 9:54 PM

I have the Cult Match Casettes Hub and the Cult hub guard that replaces the hardware, well i taco-d my rim and need to relace the hub to a new rim, but the hub guard is stuck on the hub, and its a threadless guard it should just slip off, any solutions?

|

6/12/2013 9:57 PM
Edited Date/Time: 6/12/2013 9:57 PM

put some penetrating oil or anti seize oil on it and also use something like a Flathead screwdriver to wedge it off

|

MIDWEST MOTHER FUCKER

Bike Check
Bought from Tomdon, and ScramHype

6/12/2013 10:05 PM

i sprayed a little WD40 (its all i got) and tried the flathead with a mallet idea, the thing wont even budge

|

6/12/2013 10:13 PM

yeah i dont think wd40 will do it get some JB80 that might work better but idk its all i got right now

|

MIDWEST MOTHER FUCKER

Bike Check
Bought from Tomdon, and ScramHype

6/12/2013 10:18 PM

ok ill give it a try

|

6/12/2013 10:19 PM

it was probally caused by tightining the balls out of your wheel and it smashed into ur hub i would get grese and pound it and if that dosnt work take it to ur LBS and see what they can do

|

Save a tree

Ride a Bike...... I am an environmentalist jk hahaha



BIKE CHECK: http://www.vitalbmx.com/community/WallmartBMX,103987/setup,83842




WATCH MY NEW EDIT IM SO PROUD OF IT!!

6/12/2013 10:31 PM

monkey wrench. Not even kidding. or clamp the guard in a vice and use the allen key insert in the axle and unthread it.

I had the front match guard and it threaded onto my Mary-Kate hub. I was beating the shit out of it to get it off once before and it would not come off. So I took a monkey wrench to it to see if it just needed popped loose and noticed it started unthreading.. Only had it for a few weeks at that point, they get threads dug into them quick

|

6/12/2013 10:32 PM

the pounding isnt working and i do tighten my wheel pretty hard i didnt know the guard could smash into the hub and get stuck though

|

6/12/2013 10:41 PM

sundaybmxRR wrote:

monkey wrench. Not even kidding. or clamp the guard in a vice and use the allen key insert in the axle and unthread it.

I had the front match guard and it threaded onto my Mary-Kate hub. I was beating the shit out of it to get it off once before and it would not come off. So I took a monkey wrench to it to see if it just needed popped loose and noticed it started unthreading.. Only had it for a few weeks at that point, they get threads dug into them quick

haha no shit it really does? thanks for the tip man and i have the cult front hub too but a gsport hub guard lol, ill let you know how it goes !

|

6/12/2013 10:44 PM

was it hella tight when turning the axle?

|

6/12/2013 10:50 PM

Evol BMXer wrote:

was it hella tight when turning the axle?

A little. Those guards are really weak, I had to put a small steel spacer in between the bearing & the guard cause the guard deformed a little bit over the bearing race causing it to have some drag. Might be what yours is doing. When you get it off spin it then without the guard on it and see if it still feels tight

|

6/12/2013 10:54 PM

Evol BMXer wrote:

was it hella tight when turning the axle?

sundaybmxRR wrote:

A little. Those guards are really weak, I had to put a small steel spacer in between the bearing & the guard cause the guard deformed a little bit over the bearing race causing it to have some drag. Might be what yours is doing. When you get it off spin it then without the guard on it and see if it still feels tight

its giving me hella resistance, to the point where it wont even turn anymore

|

6/12/2013 11:03 PM

Evol BMXer wrote:

its giving me hella resistance, to the point where it wont even turn anymore

My front was like that, spray some WD40 in there and let it sit for a few minutes then try

|

6/12/2013 11:06 PM

sundaybmxRR wrote:

My front was like that, spray some WD40 in there and let it sit for a few minutes then try

ok ill give it a shot

|

6/12/2013 11:12 PM

Evol BMXer wrote:

its giving me hella resistance, to the point where it wont even turn anymore

sundaybmxRR wrote:

My front was like that, spray some WD40 in there and let it sit for a few minutes then try

Evol BMXer wrote:

ok ill give it a shot

THANK YOU SO MUCH MAN MUCH APPRECIATED! IT WORKED! Thanks for helping me ive been trying everything and it finally came off!

|