My tyre just exploded!

Related:
Create New Tag

8/10/2017 12:47 PM

So I just finished spray painting my back wheel. I put the tube and tyre on an dm started pumping. I usually go for 70psi and I'd only got up to 45ish and then BOOM. My tube explodes. My ears were ringing and my right ear still feels blocked half an hour later. No idea why it blew. Do I need a new tyre or should it be ok?

|

An Indian on a small bike

8/10/2017 12:49 PM

When you say exploded, do you mean a literal hole got blown in your tire? Or did the bead peel off the rim? Post some pictures.

I'd say get a new tire

|

Ride hard or Ride home.
Pink N’ Pretty

Instagram
@tarsales

8/10/2017 12:52 PM

DanTheBikerMan wrote:

When you say exploded, do you mean a literal hole got blown in your tire? Or did the bead peel off the rim? Post some pictures.

I'd say get a new tire

The tube blew.. I'll post a picture in a little bit.

|

An Indian on a small bike

8/10/2017 1:11 PM
Edited Date/Time: 8/10/2017 1:12 PM

So your tube popped but tire structure is fine. If its still holding a bead then just get a new tube and make sure you have rim strips bro... Could a had a pebble or something sharp fall under the tube when you installed who knows.

|

8/10/2017 1:12 PM

DanTheBikerMan wrote:

When you say exploded, do you mean a literal hole got blown in your tire? Or did the bead peel off the rim? Post some pictures.

I'd say get a new tire

Ved_goswami wrote:

The tube blew.. I'll post a picture in a little bit.

Happened to me too recently after I switched from 2.3 to 2.4 tires in the back. That shits fukin LOUD, especially if the tire is near your ear when it explodes. The tube had a huge hole half way across the whole tube on the rim side. Happened to 2 tubes. I dont know what caused it but they both exploded at 3.7 bars(53 psi). After that pumped the next tube on 40 psi, rode 2 days then pumped them back to 60 psi, this time they didnt explode...
No idea what caused it, me myself and my lbs checked the rim for any spoke piercings or scrapped paint. Didnt find any. From this experience Im really scared now to pump my tires...

Picture: 2 Tubes exploded like this for me(a used one and a new one)

Photo

|

Wake up, ride, have fun, repeat.

8/10/2017 1:33 PM

Photo

Photo

|

An Indian on a small bike

8/10/2017 2:46 PM

DanTheBikerMan wrote:

When you say exploded, do you mean a literal hole got blown in your tire? Or did the bead peel off the rim? Post some pictures.

I'd say get a new tire

Some pictures there

|

An Indian on a small bike

8/10/2017 3:22 PM

Looks like the bead split

|

8/10/2017 3:36 PM
Edited Date/Time: 8/10/2017 3:41 PM

If the bead of the tire is fine, check for holes in the tire and then install. AIR SLOWLY and check to make sure the bead is not slipping off the rim. Likely you had a pinched tube or the tire slipped off the rim causing it to blow. Sucks more when you are in a closed off space that is tiny. I was basically deaf for a day because of that. SUCKED.

If the bead is shot, get a new tire.

|

"Hey anybody ever make that mistake like right when you wake up in the morning and you believe in yourself?" -Kyle Kinane

"BIKES!" -Tom Segura

8/10/2017 4:24 PM

dave lawrence wrote:

If the bead of the tire is fine, check for holes in the tire and then install. AIR SLOWLY and check to make sure the bead is not slipping off the rim. Likely you had a pinched tube or the tire slipped off the rim causing it to blow. Sucks more when you are in a closed off space that is tiny. I was basically deaf for a day because of that. SUCKED.

If the bead is shot, get a new tire.

Is the bead shot here?Photo

Photo

|

An Indian on a small bike

8/10/2017 4:25 PM

seanthemechanic wrote:

Looks like the bead split

Posted some more pics and that's where I think

|

An Indian on a small bike

8/10/2017 4:31 PM

Defective tube 100% .

I got these 2$ a piece tubes from some shitty ass thrift store , and it's like an open - building so no windows or AC . Literally EVERY tube blew at about 40 PSI . My guess is piss poor quality and constant temperature changes fucked with the compound of the rubber .

|

Instagram : braydenbuckingham
My Cult 2 Short

8/10/2017 4:42 PM

Brayden_Buckingham wrote:

Defective tube 100% .

I got these 2$ a piece tubes from some shitty ass thrift store , and it's like an open - building so no windows or AC . Literally EVERY tube blew at about 40 PSI . My guess is piss poor quality and constant temperature changes fucked with the compound of the rubber .

I got my tube from a bike shop for 6 pounds which I think is like 8 dollars so I'm not sure

|

An Indian on a small bike

8/10/2017 4:49 PM

Brayden_Buckingham wrote:

Defective tube 100% .

I got these 2$ a piece tubes from some shitty ass thrift store , and it's like an open - building so no windows or AC . Literally EVERY tube blew at about 40 PSI . My guess is piss poor quality and constant temperature changes fucked with the compound of the rubber .

Ved_goswami wrote:

I got my tube from a bike shop for 6 pounds which I think is like 8 dollars so I'm not sure

Weird . Doesn't mean it wasn't defective though . Tubes are always pre inflated before getting sold , I'm not sure to what PSI though . I imagine the factory tested it to a low amount just to see if it retained air and maybe it was at the higher PS that made it blow .

|

Instagram : braydenbuckingham
My Cult 2 Short

8/10/2017 5:26 PM

Brayden_Buckingham wrote:

Defective tube 100% .

I got these 2$ a piece tubes from some shitty ass thrift store , and it's like an open - building so no windows or AC . Literally EVERY tube blew at about 40 PSI . My guess is piss poor quality and constant temperature changes fucked with the compound of the rubber .

Ved_goswami wrote:

I got my tube from a bike shop for 6 pounds which I think is like 8 dollars so I'm not sure

Brayden_Buckingham wrote:

Weird . Doesn't mean it wasn't defective though . Tubes are always pre inflated before getting sold , I'm not sure to what PSI though . I imagine the factory tested it to a low amount just to see if it retained air and maybe it was at the higher PS that made it blow .

Might have been. But I think it might have been what Dave said about it slipping off the run

|

An Indian on a small bike

8/10/2017 6:03 PM
Edited Date/Time: 8/10/2017 6:06 PM

Ok EVERYONE hold the fuck up. This happened to me before, all that happened was that the tire bead wasnt seated in the rim properly. As in it wasnt pushed on all the way. The tire bead itself is NOT the problem. My tube and stuff looked exactly like that after it happened.

OP just get a new tube and make sure you push your tire all the way onto the rim. Your tire is completely okay, that rubber stripping off is normal wear and tear.

|





10/16/2018 8:17 AM

i had the same thing happen to me on brand new tire and tube. do you think the tire is still alright? or do i need a new one?
Photo

|

10/16/2018 8:58 AM

1st, let's not bump old threads.
2nd, if the bead is exposed from the tire on any level, it's time for a new tire (tyre... if you are British).

|