Need help with my BB and cranks!

Related:
Create New Tag

7/19/2013 8:43 PM

So i flopped my sprocket to the left side because i got a LHD rim . And ever since i did that my crank has been making a weird cracking noise . kinda also feel likes it slipping . what happened? should i keep riding it or what? HELP PLEASE!

|

If you can ride it RIDE IT!

7/19/2013 8:53 PM

You're cranks are lhd/rhd right? You didn't just switch them around did you lol?

|

45 refs and counting check profile.

7/19/2013 8:56 PM

Four wrote:

You're cranks are lhd/rhd right? You didn't just switch them around did you lol?

this

|

I'm on the vital legit list!

7/20/2013 9:51 AM

That wouldn't cause the cracking sound or the slipping unless he installed the crank arm ON the spline instead of in them which could happen with a LHD crank arm.

My guess is you bought the LHD wheel used and that the cassette on the wheel is shot.

|

7/20/2013 9:54 AM

VinKreepo wrote:

That wouldn't cause the cracking sound or the slipping unless he installed the crank arm ON the spline instead of in them which could happen with a LHD crank arm.

My guess is you bought the LHD wheel used and that the cassette on the wheel is shot.

this, it sounds like a hub problem not a crank problem

|

MIDWEST MOTHER FUCKER

Bike Check
Bought from Tomdon, and ScramHype

7/20/2013 10:00 AM

Just to start off there's no such thing as an LHD rim, there's LHD hubs.
Seconds were your cranks LHD/RHD compatible, if no have you flipped them the other way around, if yes then it's most likely your pedals coming loose.
Just give us some details, what's the noise, are all the parts moving normally, pics etc.

|

"Are they punkin' me Tio, are they punkin' me?"

7/20/2013 10:21 AM

andyferly wrote:

Just to start off there's no such thing as an LHD rim, there's LHD hubs.
Seconds were your cranks LHD/RHD compatible, if no have you flipped them the other way around, if yes then it's most likely your pedals coming loose.
Just give us some details, what's the noise, are all the parts moving normally, pics etc.

The details are there:

Noise: cracking sound

Part movement: Feels like his cranks are slipping

How does that sound like a pedal coming loose? It's most likely the hub. We just need to know if he bought it used or not.

|

7/20/2013 10:48 AM

andyferly wrote:

Just to start off there's no such thing as an LHD rim, there's LHD hubs.
Seconds were your cranks LHD/RHD compatible, if no have you flipped them the other way around, if yes then it's most likely your pedals coming loose.
Just give us some details, what's the noise, are all the parts moving normally, pics etc.

VinKreepo wrote:

The details are there:

Noise: cracking sound

Part movement: Feels like his cranks are slipping

How does that sound like a pedal coming loose? It's most likely the hub. We just need to know if he bought it used or not.

Loose pedals cause a rattling kind of sounds, I assumed so considering that fact that the crank arms have a specific thread for each side.
Re-reading what he wrote I'm pretty sure it's the hub skipping, I didn't catch what he meant at first with cranks slipping, but I think I know what he means.
OP does this happen often?
To see what the problem is exactly the best thing you could do it take a part the hub and check the internals for damage or wear.

|

"Are they punkin' me Tio, are they punkin' me?"

7/20/2013 10:35 PM

I did switch my cranks around . All i did was remove the cranks arms and switched around. And i did get my back set up used in a trade . the driver seems kinda loose . it just occasionally slips . is it because my sprocket is kinda worn out? as in the teeth are hella sharp and some arent the same height anymore

|

If you can ride it RIDE IT!

7/20/2013 11:18 PM

thatonetooththoee_ wrote:

I did switch my cranks around . All i did was remove the cranks arms and switched around. And i did get my back set up used in a trade . the driver seems kinda loose . it just occasionally slips . is it because my sprocket is kinda worn out? as in the teeth are hella sharp and some arent the same height anymore

To switch sides, i think you shouldn't reverse the crank arms, instead you'd pull the right arm off, remove the sprocket, put the arm back on, then remove the other arm, and put the sprocket on.. they are marked left/right, because they have specific threading for the pedals..check them to be sure your pedals aren't coming loose.. also, you should check the bb bearings.. with the arms off, turn the spindle to see if it turns smoothly or a little bit rough.. sometimes the bearings get damaged during crank removal/installation.. then check the chain alignment, to see if you aren't using the cone spacer or washers on the wrong sides.. other than those things, i got nothin..

|

Stupidity, outrage, vanity, cruelty, iniquity, bad faith, falsehood - we fail to see the whole array when it is facing in the same direction as we.
-- Jean Rostand

7/21/2013 10:44 PM

thatonetooththoee_ wrote:

I did switch my cranks around . All i did was remove the cranks arms and switched around. And i did get my back set up used in a trade . the driver seems kinda loose . it just occasionally slips . is it because my sprocket is kinda worn out? as in the teeth are hella sharp and some arent the same height anymore

Jèff_Béckförd wrote:

To switch sides, i think you shouldn't reverse the crank arms, instead you'd pull the right arm off, remove the sprocket, put the arm back on, then remove the other arm, and put the sprocket on.. they are marked left/right, because they have specific threading for the pedals..check them to be sure your pedals aren't coming loose.. also, you should check the bb bearings.. with the arms off, turn the spindle to see if it turns smoothly or a little bit rough.. sometimes the bearings get damaged during crank removal/installation.. then check the chain alignment, to see if you aren't using the cone spacer or washers on the wrong sides.. other than those things, i got nothin..

i actually re greased my bearings and it didnt happen as much . i still happened but not as much as when i switched it without re greasing them , maybe i do need to flop the cranks . thing is my allen key bolt is stripped . anybody have ideas on how to re thread them?

|

If you can ride it RIDE IT!

7/22/2013 10:47 AM

Can you post a vid of it?

|

7/22/2013 8:23 PM

VinKreepo wrote:

Can you post a vid of it?

what do you mean bro?

|

If you can ride it RIDE IT!

7/25/2013 10:50 PM

I actually found out what happened . My hub was fine . my cranks arms are compatible with LHD hubs . I had my cranks on backwards .

|

If you can ride it RIDE IT!