Related:
Create New Tag
alsd47 alsd47
9/1/2015 10:44 PM

So its almost been a year since ive owned the freemix, had to replace some bearings several months ago and it ran great till today, i saw that i needed to adjust my chain so i went got it nice and tight, as soon i started riding it felt completely off like the hub got hard to pedal almost, and then i started not being able to pedal at all, and then it would work for a while and then start it again, i went home took it apart, and saw nothing out of the norm, no metal shavings either, so i figured maybe it just needs to be lubed again, did that and it ran great for a couple hours, then i tried some feeble hard 180s and then it came back again, is it just time for a new hub? Or is this somehow possible to fix, and from where im from bike shops dont know shit bout bmx let alone a freecoaster

| Quote
Brayden_Buckingham Brayden_Buckingham
9/1/2015 11:30 PM

Grease everything and praise the sun !

Instagram : braydenbuckingham
My Cult 2 Short

| Quote
Liam82 Liam82
9/2/2015 1:52 AM

Maybe contact Primo about it and tell them what you said and see what they say to do about it

| Quote
dave lawrence dave lawrence
9/2/2015 6:04 AM

Check the clutch ring and see if there is wear markings on it?

"Hey anybody ever make that mistake like right when you wake up in the morning and you believe in yourself?" -Kyle Kinane

"BIKES!" -Tom Segura

| Quote
HardBMX_Tim HardBMX_Tim
9/2/2015 9:31 AM

Make sure the clutch is properly greased and not worn. Another thing that comes to mind is that your axle could be bent around the clutch area?




Refs : SnM An1mal, GThompson121, Chuck8273, blizzbikes, bmxsteve99, kevin.brock.338, zinum, Brian_Griffin, billyhandyjunior, riverM, tomdon
Instagram : @timhankinsbmx


| Quote
Mychaylo Mychaylo
9/2/2015 10:02 AM

Sounds like the clutch is actually stuck in the hub and not engaging, it can happen when they run dry

| Quote
Gsport George Gsport George
9/2/2015 4:24 PM

Have a feel inside the clutch and see if the ball springs have worn a groove. Usually when a FC hub wont enagage its because the resistance mechanism isnt offering enough resistance...

| Quote
alsd47 alsd47
9/3/2015 12:27 PM

thx guys i pull it apart tonight again and take a look, ill post some pics of it if i cant find anything

| Quote

Post a Reply

Cool Wink Smile Tongue Laughing Shocked Sick Angry Blink Sad Unsure Kissing Woohoo Grinning Silly Pinch Sideways Whistling Evil Dizzy Blush Cheerful Huh Dry

See All Deals ยป

THE SHOP