Setting up a new Half Link Chain

Related:
Create New Tag

5/24/2013 2:04 AM

Ok so basically I brought a WE THE PEOPLE volta and I got is all set up and went to ride and there was a crazy grinding horrid noise coming from the chain ( Saltplus Warlock half link ) I tried all sorts and gave up and replaced with a Cult 510 and now rides as you would expect.

Since then people seem to rave about either how good or bad they are but I feel i didnt give it enough of a chance.

the issue was it seemed the pitch was to small and at the rear driver each turn the links snapped into place rather than glided. I did note when i removed it the the links were tight as and even hard to work in my hands and not smooth at all. is this normal?

anyway I would like abit of advice to how people set there new half link chains up and any bedding in tips.

Cheers

|

5/24/2013 2:21 AM

The halflink just needed to break in, ride it for like a week and it should go away.

|

5/24/2013 9:03 AM

brianoob wrote:

The halflink just needed to break in, ride it for like a week and it should go away.

This .

|

don't overthink it just do it !

5/24/2013 4:19 PM

Yea it should be fine. That's what my shadow does

|

Old bike VVV

California Living

I now have a more or less stock sunday scout with a complete Demo rear wheel. Sue me

5/24/2013 5:02 PM

it just needed to be broken in

|

Save a tree

Ride a Bike...... I am an environmentalist jk hahaha



BIKE CHECK: http://www.vitalbmx.com/community/WallmartBMX,103987/setup,83842




WATCH MY NEW EDIT IM SO PROUD OF IT!!