brakes question

Related:
Create New Tag

4/17/2008 7:19 PM

ok so i was putting new pads on my bike, and somehow (my luck) the spring comes loose. so i loosen the spring on the other arm. now my brakes just move freely. My question is: how far do i rotate the springs before i tighten them down? or any other tips would help. basically anything to get my brakes running again i guess haha

thanks.

|

4/17/2008 7:40 PM
Edited Date/Time: 4/17/2008 7:40 PM

one quarter turn on each Smile

|

4/17/2008 9:04 PM

ok, but i do turn it a quarter, tighten it, and my brakes still feel loose a give way too much. they still dont spring back enough. i think i need new springs maybe?

|

4/17/2008 9:24 PM

Check and make sure you have the springs on the correct sides, if you have them backwards then they kind of counter-act themselves. I put about a quarter turn of tension then hold the allen key there and tighten. you may need to micro adjust things here and there. Make sure you have just a bit of toe-in on your brake pads. If you get your brakes just right then you should be able to pull your lever with one finger very effortlessly, and have them lock. Eagle claw 2 brake pads with a nice chrome rim and you could have 3 fat guys jumping on your forward pedal and not go anywhere with that shit locked up. Just keep tinkering with it and pay attention to how each adjustment effects the preformance...you'll get them dialed in no time!

|

Function before fashion...

4/17/2008 9:42 PM

ok thanks. arent you the guy I was arguing with about gyro vs. straight cable? haha well thanks for the help

but i guess the reason the arms had so much play in them is because i have a very messed up spring.it was just so tweaked that it wont work at all. i need to order a new pair.

thanks guys!

|

4/17/2008 9:46 PM

Hey dude, fuck arguing...my bad. Im not one to keep on with shit but i guess i couldn't get my exact point across. I'm super anal about my brakes so i know how frustrating that shit is...what kind of brakes and pads you running?

|

Function before fashion...

4/17/2008 9:53 PM
Edited Date/Time: 4/14/2016 4:06 PM

ha its cool bro. brakes are a damn hassle...


im running evo 2's, and I had the original stock pads that come with them, but i just got my new kool-stop eagle 2 pads today. shame my springs are fucked up, i was looking forward to trying the pads because everyone on here recommended them. oh well i can get springs from my local shop pretty easily.

|

4/17/2008 9:59 PM

i have the same set up.. the evo 2's come with 2 different spring sets. one thick and one thin...i use the thinner ones for less resistance on pull, do you know which ones you have on??? Eagle2's are the shit and don't let anyone tell you otherwise. Try lightly sanding them down a bit...just take that freshness away. a light sanding will kind of break them in a bit and get them a bit softer, resulting in a bit better braking. If i can help you out in any further way lemme know, i know how to work me some brakes!

|

Function before fashion...

4/17/2008 10:03 PM

haha yeah but im currently kicking myself in the face for losing the other set of springs haha. IM SO STUPID, but its not too big of a deal. do you know where I can find a set of replacements? i tried dans and did a google but i cant find anywhere. its bugging me.

and thanks in advance!

|

4/17/2008 10:22 PM

Damn, try odyessybmx.com. I'm not sure if they sell springs individually but it would be your best bet to get something that works best with the evo2s you have. If they dont have it on the website try and drop them an e-mail. If they cant get you the springs im sure they can tell you where to get some that'll work with the evo2s. No problem too, if you need anymore help you know where to get it.

|

Function before fashion...